SKUAD.jar v0.1_b12

Changements par rapport à la version v0.1_b11 :
  • skuad.uda : correction d’un bug mineur dans le composant device skuad.uda.gui.device.DLight.
  • lanceur : ajout des options « -i », « -ir » et « -irt » dans le lanceur SKUAD (-> v1.03). Ces options permettent d’installer de façon automatique un composant SKUAD depuis une archive .zip (plus besoin de faire la décompression manuellement).
  • lanceur : le lanceur SKUAD est maintenant compatible Java 9. Il affiche également un message d’alerte si la version active de Java n’est pas compatible avec l’un des modules présents (par exemple java 9 pour la librairie GeoTools).
  • lanceur : ajout de la gestion des dépendances entre module SKUAD (présence et version minimale) dans le lanceur SKUAD, et l’option de lancement -m permet de vérifier si tout est ok pour l’ensemble des modules présents. De plus, le lancement d’un programme dont les dépendances ne sont pas remplies affiche un message clair pour signaler le problème.
  • lanceur : ajout de l’option « -clean » dans le lanceur SKUAD. Cette option permet de supprimer toutes les librairies obsolètes présentes dans le dossier lib.
  • divers : les éléments de code spécifique au Raspbery Pi sont maintenant transférés dans un module additionnel dédié au Raspberry PI (le module ModPi).
  • divers : suppresssion des mentions « _a_dezipper » dans le nom des packs de déploiement de la librairie SKUAD (ce sera la même chose pour les autres composants).

Laisser un commentaire

Votre adresse de messagerie ne sera pas publiée. Les champs obligatoires sont indiqués avec *